April 17, 2021

Grizzly G0720R / SX4 Won't Start – Wiring Problems?

2 min read
I’m trying to wire up my Grizzly G0720R that’s been disassembled for a few years...

I’m trying to wire up my Grizzly G0720R that’s been disassembled for a few years and I can’t get it to work correctly. I wired everything up according to the instruction manual, but it has a couple of problems:

1. The LCD turns on and always displays "Forward" and "Stop". I can’t get it to turn the spindle on. Hitting the Start button seems to do nothing.

2. The elevation motor begins spinning as soon as I turn the machine on. Since I’m doing a CNC conversion I don’t need it, but it does seem strange that the motor (which is wired up but sitting beside the machine) wants to turn for no apparent reason. If I hit the "up" button the motor will stop until I release the button.

Reading a manual for a similar SX4 clone, it says that you can’t mill while the elevation motor is moving, so maybe the spindle won’t turn on for this reason. Looking at the wiring schematic, I don’t see how it *wouldn’t* do this. If you follow the path of the electricity, it feeds right to the blue wire of the motor even if no buttons are pressed.

Here’s the schematic:

G0720WiringDiagram.jpg

G0720WiringDiagram2.jpg

When you look at the part of the schematic with the Up/Down buttons, keep in mind that the top 2 terminals of the switch are not connected to each other when the button isn’t pressed. The bottom 2 terminals are connected. When you press the button, this behavior reverses, with the top 2 becoming connected to each other and the bottom 2 becoming disconnected.

Here’s the button:

Button1.jpg

And here’s the LCD:

LCD1.jpg

Thanks for any suggestions.

Attached Images

Source link

Copyright © All rights reserved. | Newsphere by AF themes.